Moodle 3.7 or later requires at least PHP 7.1.0 (currently using version 5.6.30-0+deb8u1). Some servers may have multiple PHP versions installed, are you using the correct executable?